Using PPA Repositories with Debian add-apt-repository Script

Looking for a way to replicate PPA repositories into your Debian squeeze or wheezy install? Anantshri has you covered with a quick shell script. Note that it may break your installation horribly and kill puppies wantonly.

For installing Bisigi Themes for the gnome desktop? Worked for me.

Changing Default Applications for the Gnome Desktop

Ever wanted audio, text, or video to open up in a different application than whatever Debian has slotted for your default? Want to get down to the nuts and bolts and do it manually?

Well then. Take a look at /etc/gnome/defaults.list for what application is used to open up what extension or mime-type, and bring up the /usr/share/applications/ directory for the configuration files that dictate how that application is going to open up.

For instance, I changed .pls and .mp3 from Totem (possibly the last media application installed) over to audacious2-gtkui for better integration with the look and feel of the gnome desktop.

RAID-5 Array Not Responding Due to One Dropped Drive

An interesting thing happened on the way to backing up the VM server this weekend. And by interesting I mean mindbendingly horrible.

So I’m pulling down the array for a backup. Not that odd in and of itself. And then I start getting spurious IRQ requests (it’s spamming the crap out of the line) that crash out one of the HDDs on the array and render the machine frozen.

OKAY. That’s why we have a RAID-5 array in the first place.

When I bring the machine back up it chokes with some errors on the RAID initiation. Apparently it doesn’t think there are enough drives in the array anymore to bring up the primary /dev/md1 array that holds all our precious data. Excellent, I love spending a weekend de-mucking dead servers :/.

Naturally I don’t want to compound issues, so I pull a backup of each of the bloody 300+ GB drives to a recently verified good (off it’s third RMA.. hardware incompatibility rather than mechanical flaws) 640GB backup drive. This takes roughly a day.. but it’s worth it if the drives die in the middle of a recovery effort.

I’ve got everything pretty straight data-wise, no real fear of doing worse damage at this point. Cracking open mdadm to do a examine on the arrays reveals something a bit weird though. The drives, two of them anyway, show that they’re still okay…

Turns out that the system hit the third drive in the array first, saw that it reported a failure of the entire array, and went no further. The other two drives in the array report as working fine.. and do. I did a –assemble sans funky drive and the array came right up for me to pull a quick backup.

Now I’ll just re-add the “dead” drive to the array and have it re-build once the backup is finished.

So, if you’re staring at an array that won’t come up take a closer look at the mdadm output to make sure it isn’t just hanging on a single debilitated drive. Although I’ve never seen this happen before, restoring a single drive sure beats restoring off backup medium.

KDE4 Revisited, Adding Widgets to the Panel

Now that there’s a new point version and I’ve had a chance to work KDE4 over properly, I thought it time to revisit it. As it turns out, putting a widget on the KDE4 panel isn’t all that hard.

To add a widget to the panel instead of adding it to the desktop, simply click on the star on the widget dialog. Then left click and drag the star to the place you’d like it on your toolbar (is that still kicker? no idea). Pretty simple, just not intuitive.
1399
Adding items from the K-Menu is much easier. Just right click and select “Add to Panel”. Way to use the same methodology across the desktop guys ;p. Might want to have a right click add-to-panel method in the widget dialog as well as that’s a comprehendable way of doing things.

So far the layout is fairly usable, although the icons having a huge transparent block around them is still disconcerting. It seems a bit of unnecessary clutter and looks funky.

Note that this is after updating to Xorg 1.3 and KDE 4.0.0.1. Everything appears to work fine, and I’m not seeing that odd OpenGL performance hit that the systems took running KDE 3.5.

Current verdict is that there’s still quite a bit of work to be done but the release is usable and fairly clean. Good job.

Updating KDE4, Xorg from Ubuntu to Debian

Going with the old apt-get source.list rotation to switch from Ubuntu to Debian. Since Debian appears to have a working KDE4 repository and a shiny new version of Xorg in their bleeding edge tree I’m going to give it a whirl.

We’ll see if the machine is better or worse after an update to the latest, greatest, and potentially flaky.

KDE4 Released, Not Really Ready Already

So I’ve been seeing the pictures of KDE4, but haven’t really had a chance to play with it until now. But write-ups over at places like Ars have led me to believe it’s usable, if not stable.

Sitting at a laptop running KDE4 on Ubuntu 7.10 I can assure you this is not the case.

While the technology behind this desktop feels like it might, someday, be impressive it’s currently a steaming pile of not-ready-yet. If this was my introductory experience to KDE i’d run, not walk, screaming and not look back.

Configuration options for most of the stuff that needs to be configured are missing, display glitches abound, and my clock currently contains a flashing garbage block where the last digit should be.

Also, every other character makes the quad desktop switcher in the corner flash on and off like a mad strobe light.

I don’t even have a dock panel on the dock. There’s no option for the dock in the config screen either. Instead, I had to get a widget of my dock that sits on the desktop. Underneath everything else.. which is quite obnoxious.

The default icon set and theme aren’t thrilling, either. If you’ve seen any KDE4 previews, that’s what you’re getting.. and nothing else. If this is our future then I think I’ll hold onto the past until it’s not filled with rubbish, thanks.

It’s ACER 4520 Laptop Time!

Seems that Shogun and I over on the #PCBurn channel (on irc.freenodel.net) both decided to update the laptops at the same time, and both got ACER 4520s.

His’ll probably run the stock Vista OS with Ubuntu as a dual boot. Mine will never see the original OS and I’ll probably make an inquire to someone with greater legal knowledge than mine if the manufacturer is bound to issue me some sort of refund with the given legal language in the Microsoft EULA.

While I do appreciate the manufacturers unwillingness to part with any amount of money, especially with those lucrative Microsoft kickbacks, I still don’t want to pay for something I won’t use. So we’ll see what my states duly appointed legal representatives think of the agreement.

If it doesn’t entitle me to anything I’m not going to be too disappointed, honestly. I’m just not sure what they’re bound to honor is all. And I figure that’s what those people hold office to inform me of.

As for the machine, it’s internals, specs, and how to rip it apart to replace/add parts.. that I’ll do a segment on over at pcburn.com. I’ve missed out on the last few machines, but writing time’s been tight between work and non-work.

Blizzard Goes and Pulls the Rug out from my Testing

So I’m doing a lot of subjective testing with WoW and a few different setups, trying to get a feel for how it performs before moving onto another game or two. All just play through stuff, far too much of the game to actually be fun, really.

And what does Blizzard do halfway through my framerate runs to figure out what influences the gameplay? Change the general settings.

So. Now I’ve gotta go pull a few rigs out and go through all the World of Warcraft game testing again.

Although one thing seems to have had a fairly big affect. Turning off the tickless kernel option and switching to the CFQ scheduler from deadline seems to have cleaned up some I/O inconsistency issues. Now it gets a bit catchy in odd spots (like when you’re taking off on a flight path) but the overall performance is fairly consistent and doesn’t hang up on any particular points when fighting or actually playing.

So far it’s been a pretty good experience with the current release of WINE.

World of Warcraft as a Benchmark of GPU Performance (on Linux)

So WINE and WoW do, in fact, make a good benchmark of system performance for Linux. Unfortunately I’m now butting up against the fact that it absolutely and sometimes erratically flatlines the system.

It doesn’t kill the box, but I’m seeing 100+% CPU usage runs on the dual core. This creates a slight problem.

So… I need to actually find some machinery that can run WoW (or whatever I end up benchmarking with for the article) at something under full throttle.

That and I need to cobble together a Windows release for some cross platform testing. I’m not positive it’ll perform any better under the native OS, but I am pretty sure the driver support on the video side will be more refined.

Ah well. Back to hacking.

World of Warcraft on the ATI 200M Notebook GPU

Currently I’m working on a gaming and graphics cards article for PCBurn, and I’ve finally got the ATI 200M integrated on my Compaq laptop running World of Warcraft. As it wouldn’t give me more than blurry squiggels in DirectX 9 and wouldn’t run in OpenGL previously this is pretty cool.

It’ll work okay with all the eye candy turned off at 1024×768 as long as I’m not going through a very densely populated area. Oh, and this is using WINE 0.9.48 along with ATIs latest drivers as of Nov. 6, 2007 on Linux. I’m assuming it runs some variation of “better” on Windows, but I could be wrong.

Also note that the useful information on *how* to do this will be contained and linked to over on PCBurn once I get the article done.